Versions Php obsolètes : comment mettre à jour PluXml ?

Si vous utilisez le CMS sans base de données PluXml et que votre site est hébergé chez OVH, il est possible que vous ayez reçu un mail vous informant que les versions PHP obsolètes se seraient plus maintenues. Comment mettre votre site à jour ?

Une simple modification du htaccess

Pour des raisons de sécurité, OVH a décidé de ne plus supporter les versions PHP obsolètes suivantes à partir du 24 septembre prochain :

  • PHP 4.x (fin de vie depuis plus de 6 ans)
  • PHP 5.2 (fin de vie depuis plus de 4 ans)
  • PHP 5.3 (fin de vie depuis plus de 8 mois)

Si vous avez reçu un tel mail, c’est que vous êtes directement concerné car vous devez avoir un site propulsé par PluXml qui est sur un hébergement mutualisé OVH.

Coupure des version php obsoletes mise à jour de FluXml

Pour éviter la coupure et passer en PHP 5.4, il vous suffit de modifier votre .htaccess (avec Notepad++), tout simplement en y ajoutant les lignes ci-dessous :Review Android Smartphone

Ce bout de code a été trouvé sur le wiki de PluXml qui propose également des solutions pour d’autres hébergeurs comme Free, Online.net, 1and1 ou Nuxit.

Modification : Suite au commentaire (pertinent !) de wam que je remercie, vous n’aurez plus accès au .htacces chez OVH le 24 septembre. En revanche, vous trouverez un .ovhconfig à la racine de votre site. Dans le cas contraire, créez-le en transférant sur votre serveur un fichier ovhconfig.txt que vous renommerez ensuite en .ovhconfig. Celui-ci devra contenir :

Vous avez aimez cet article ? Partagez-le !

2 réponses à “Versions Php obsolètes : comment mettre à jour PluXml ?

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *